1. 首页
  2. 服务器运维
  3. Linux

编译安装php7.3错误libzip must be upgraded to version >= 0.11

在老的linux系统(比如ubuntu 14.04,centos6)中手动编译安装php7.3的时候,一般都会碰到“system libzip must be upgraded to version >= 0.11”这样的错误。根据提示我们可以清楚的知道是因为系统自带的libzip版本低了,所以这里我们需要安装最新的libzip。

Xnip2019-09-18_20-33-19

在安装libzip之前可以先卸载系统自带的libzip,不过博主这里不建议这样做,因为对于老的系统不清楚是否有其他程序会有依赖老libzip库。

官网下载并编译安装

wget https://libzip.org/download/libzip-1.3.2.tar.gz
tar xvf libzip-1.3.2.tar.gz
cd libzip-1.3.2
./configure --prefix=/usr/local/libzip-1.3.2
make && make install

然后编译php7.3的时候添加或修改libzip的库地址

./configure --with-libzip=/usr/local/libzip-1.3.2

成功后在make && make install就可以了。

原创文章,作者:章郎虫,如若转载,请注明出处:http://www.szl724.com/sysmaint/linux-os/3251.html

联系我们

0574-55011290

QQ:248687950

邮件:admin@nbhao.org

工作时间:周一至周五,9:00-18:00,节假日休息

QR code